×

Notice

The forum is in read only mode.
×
Getting new Releases

To get notified on new releases you may follow us on twitter @expandframework or subscribe in our main RSS feed.

Topic-icon VSIX Paket Error in 17.1.3.7

  • wolffc70
  • wolffc70's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
1 year 10 months ago #10903 by wolffc70
VSIX Paket Error in 17.1.3.7 was created by wolffc70
Hi Tolis,

the VSIX Paket in 17.1.3.7 got an error by installation. The Toolbox is also not created and empty.

Here is the log from VS, I hope this helps.

<entry>
<record>838</record>
<time>2017/06/18 09:26:56.332</time>
<type>Error</type>
<source>Xpand.VSIX.VSPackage.VSPackage</source>
<description>bindings:System.Object[]&#x000D;&#x000A;System.ArgumentException: Falscher Parameter. (Ausnahme von HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A; bei EnvDTE.Command.set_Bindings(Object pVar)&#x000D;&#x000A; bei Xpand.VSIX.Commands.VSCommand.BindCommand(Object[] bindings) in C:\Release171\Xpand.Plugins\Xpand.VSIX\Commands\VSCommand.cs:Zeile 22.</description>
</entry>
<entry>
<record>839</record>
<time>2017/06/18 09:26:56.332</time>
<type>Error</type>
<source>VisualStudio</source>
<description>LegacySitePackage failed for package [VSPackage]Source: &apos;&apos; Description: Falscher Parameter. (Ausnahme von HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;System.ArgumentException: Falscher Parameter. (Ausnahme von HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A; bei EnvDTE.Command.set_Bindings(Object pVar)&#x000D;&#x000A; bei Xpand.VSIX.Commands.VSCommand.BindCommand(Object[] bindings) in C:\Release171\Xpand.Plugins\Xpand.VSIX\Commands\VSCommand.cs:Zeile 31.&#x000D;&#x000A; bei Xpand.VSIX.Commands.EasyTestCommand.Init() in C:\Release171\Xpand.Plugins\Xpand.VSIX\Commands\EasyTestCommand.cs:Zeile 28.&#x000D;&#x000A; bei Xpand.VSIX.Commands.Commands.InitEasyTest() in C:\Release171\Xpand.Plugins\Xpand.VSIX\Commands\Commands.cs:Zeile 87.&#x000D;&#x000A; bei Xpand.VSIX.Commands.Commands..ctor() in C:\Release171\Xpand.Plugins\Xpand.VSIX\Commands\Commands.cs:Zeile 15.&#x000D;&#x000A; bei Xpand.VSIX.VSPackage.VSPackage.Initialize() in C:\Release171\Xpand.Plugins\Xpand.VSIX\VSPackage\VSPackage.cs:Zeile 102.&#x000D;&#x000A; bei Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)</description>
<guid>{FA1289E0-6376-4D19-98C5-9D0C90DD3283}</guid>
<hr>80070057 - E_INVALIDARG</hr>
<errorinfo></errorinfo>
</entry>
<entry>
<record>840</record>
<time>2017/06/18 09:26:56.332</time>
<type>Error</type>
<source>VisualStudio</source>
<description>SetSite failed for package [VSPackage](null)</description>
<guid>{FA1289E0-6376-4D19-98C5-9D0C90DD3283}</guid>
<hr>80070057 - E_INVALIDARG</hr>
<errorinfo></errorinfo>
</entry>
The following user(s) said Thank You: Tolis
More
1 year 9 months ago #10904 by Tolis
Replied by Tolis on topic VSIX Paket Error in 17.1.3.7
Hi

I am afraid I couldn't find a way to repro it. What I try was clean installation as well as install over an existiing previous version. In both cases it worked fine. I used VS2015 on Win10

May you try to run the VSIX project from the source?

p.s. I will modify the course in next minor to allow the plugin to continue if command keyb binding fails, however this may not solve your case/

To get notified on new releases follow us on twitter @expandframework or subscribe RSS feed. I am also available @tolisss . Also see How to debug eXpand
Moderators: expand
Time to create page: 0.208 seconds