×

Notice

The forum is in read only mode.
×
Getting new Releases

To get notified on new releases you may follow us on twitter @expandframework or subscribe in our main RSS feed.

Topic-icon WorldCreator Module - Generated Code Issue for Persistent Assembly

  • jyoung3456
  • jyoung3456's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
11 months 4 hours ago #11657 by jyoung3456
Hi this is urgent could you please HELP!

I have existing model and I've added world creator to my project. My issue is when I add new generated code I have issues with template. Please look at the screenshot.

My Template looks like this

namespace Housing{

using System;
using System.Collections.Generic;
using System.ComponentModel;
using DevExpress.Persistent.Base;
using DevExpress.Persistent.Validation;
using DevExpress.Xpo;
using Xpand.Persistent.Base.PersistentMetaData;
using Xpand.Persistent.BaseImpl.PersistentMetaData.PersistentAttributeInfos;

using DevExpress.ExpressApp;
using DevExpress.ExpressApp.DC;
using DevExpress.Data.Filtering;
using DevExpress.ExpressApp.Model;
using DevExpress.Persistent.BaseImpl;
using DevExpress.ExpressApp.Xpo;
using DevExpress.ExpressApp.ConditionalAppearance;
using DevExpress.ExpressApp.Editors;
using DevExpress.Xpo.Metadata;

using System.Linq;

[DefaultClassOptions]
public class $CLASSNAME$:XPObject{
public $CLASSNAME$(Session session):base(session){}
public override void AfterConstruction() {
base.AfterConstruction();
}

protected override void OnSaving() {
base.OnSaving();
}

protected override void OnChanged(string propertyName, object oldValue, object newValue) {
base.OnChanged(propertyName,oldValue, newValue);
}

}
}

Where those other using statements show up and why do I always see empty using statement at the top? using{ ??

Can someone help please, this is urgent!

Thanks,

J
Attachments:
More
10 months 4 weeks ago #11660 by Tolis
I already answered you in your other post

To get notified on new releases follow us on twitter @expandframework or subscribe RSS feed. I am also available @tolisss . Also see How to debug eXpand
Moderators: expand
Time to create page: 0.179 seconds